Multi-source-xmi model generation

Description

I tried to genreate from two .uml2 file setting the andromda.xml as below:

andromda.xml:
*****************
<repository name="emf-uml2">
<models>
<model type="emf-uml2">
<uri>${neu-sample.model.1}</uri>
<uri>${neu-sample.model.2}</uri>
<moduleSearchLocations>
<location patterns="*/.uml2">${settings.localRepository}/org/andromda/profiles/emf/uml2</location>
</moduleSearchLocations>
</model>
</models>
</repository>

build.properties:
******************
neu-sample.model.1=file:${project.build.sourceDirectory}/part1/neu-sample-part1.uml2
neu-sample.model.2=file:${project.build.sourceDirectory}/part1/neu-sample-part2.uml2

The problem is that only the second(neu-sample.model.2) is generated.

The other way I tried didn't worked either:

andromda.xml:
*****************
<repository name="emf-uml2">
<models>
<model type="emf-uml2">
<uri>${neu-sample.model.1}</uri>
<moduleSearchLocations>
<location patterns="*/.uml2">${settings.localRepository}/org/andromda/profiles/emf/uml2</location>
</moduleSearchLocations>
</model>
<model type="emf-uml2">
<uri>${neu-sample.model.2}</uri>
<moduleSearchLocations>
<location patterns="*/.uml2">${settings.localRepository}/org/andromda/profiles/emf/uml2</location>
</moduleSearchLocations>
</model>
</models>
</repository>

This time the second model is generated twice...

Please!

I'm checking the source and try to send the fix.

Environment

Windorws 2003 server, maven2, AndroMDA 3.2, MagicDraw 11.6
using hibernate, spring , jsf, axis cartridges.

Assignee

Former user

Reporter

Béla Boda

Labels

None

Components

Priority

Critical
Configure