The core/pom.xml generated contains two wsdl depedencies

Description

I have generated my application with andromda 3.4-SNAPSHOT

I have noticed the following small problem: the core/pom.xml has two times the wsdl4j dependency.
I removed it manually.

Perhaps you could change the project generator in order not have this small bug?

CODE: SELECT ALL
mvn install
[INFO] Scanning for projects...
[ERROR] The build could not read 1 project [0]
[ERROR] The project eu.microme.microme_chebi:microme_chebi-core:1.0-SNAPSHOT (/env/export/nfs1/home/flefevre/tmp/andromda4/microme_chebi/core/pom.xml) has 2 errors
[ERROR] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: wsdl4j:wsdl4j:jar -> null vs null
[ERROR] 'dependencies.dependency.version' is missing for wsdl4j:wsdl4j:jar
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:

My parameters are the following :

mvn org.andromda.maven.plugins:andromdapp-maven-plugin:3.4-SNAPSHOT:generate
Please choose the type of application to generate [j2ee, richclient]
j2ee

Please enter the parent directory of your new application directory, using forward slashes (i.e. C:/workspaces):
/env/export/nfs1/home/flefevre/tmp/andromda4

Please enter your first and last name (i.e. Chad Brandon):
Francois LE FEVRE

Which kind of modeling tool will you use
(uml1.4/uml2 for .xml.zip files,
emf-uml2 for .uml2 files, emf-uml22 for .uml files,
rsm6 or rsm7 for .emx files) [uml1.4, uml2, emf-uml2, emf-uml22, rsm6, rsm7,]:
uml1.4

Please enter the name of your J2EE project (i.e. Animal Quiz):
Microme Chebi

Please enter an id for your J2EE project (i.e. animalquiz):
microme_chebi

Please enter a version for your project (i.e. 1.0-SNAPSHOT):
1.0-SNAPSHOT

Please enter the root package name for your J2EE project (i.e. org.andromda.samples.animalquiz):
eu.microme.microme_chebi

Would you like an EAR or standalone WAR? [ear, war,]:
ear

Please enter the type of transactional/persistence cartridge to use (enter 'none' if you don't want to use one) [hibernate, ejb, ejb3, spring, none,]:
spring

Please enter the Spring version to use (enter '1' for 1.x or '2' for 2.x) [1, 2,]:
2

Please enter the programming language to be used in service and dao implementations [java, groovy,]:
java

Please enter the database backend for the persistence layer [hypersonic, mysql, oracle, db2, informix, mssql, pointbase, postgres, sybase, sabdb, progress, derby,]:
mysql

Will your project need workflow engine capabilities? (it uses jBPM and Hibernate3)? [yes, no,]:
yes

Will your project have a web user interface? [yes, no,]:
yes

Would you like your web user interface to use JSF or Struts? [jsf, struts,]:
struts

Would you like to be able to expose your services as web services? [yes, no,]:
yes

Would you like to use Axis or XFire as your SOAP Stack? [axis, xfire,]:
axis

Would you like to use Axis 1.x or Axis 2.x (enter '1' for 1.x or '2' for 2.x)? [1, 2,]:
2

Environment

linux 32, java 1.6

Assignee

Former user

Reporter

Francois LE FEVRE

Labels

None

Fix versions

Affects versions

Priority

Major
Configure